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Chapter 2 
 

Installation 
 
This chapter describes: 

• System requirements 
• Installation requirements 
• How to install NDSR, non-networked 
• How to register NDSR 
• How to start NDSR 
• How to transfer NDSR registration  
• How to unregister NDSR 
• How to uninstall NDSR 
• How to install NDSR, networked 
• How to install additional setups 

 
System Requirements 
 
NDSR 2025 is supported on Microsoft Windows 10 and 11.   
 
NDSR software is tested on desktop PCs and laptop PCs running the currently supported version(s) 
of Microsoft Windows.  If you want to use NDSR with another type of setup (i.e. tablet, Apple 
device running a Windows partition) we recommend you download the free Demo version of the 
software from the NCC website to test it before purchasing the software. 
 
Installation Requirements 
 
Permissions 
Depending on your organization's security policy, NDSR 2025 is normally installed and uninstalled 
only by a member of the Administrators group.   
 
Every NDSR user must be a member of the Users group or another group that has the following 
permissions for NDSR User Data:  

• Modify. 
• Read & Execute. 
• List Folder Contents. 
• Read. 
• Write.   

 
An NDSR user must not be a member of any group (including Everybody) that lacks any of these 
permissions.  
 
Default locations of NDSR User Data:  

• Windows 10 and 11: NDSR Public Documents folder. 
 
The files of a network database service are not NDSR User Data, and should not be accessible to 
Users (only to Administrators and the SYSTEM).  
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Previous NDSR Registrations 
Because NDSR is a password-protected program, every copy and version must be registered 
(although one registration process can cover several versions--see "Registering NDSR").  Because a 
license registration is shared by several versions of NDSR, it is usually simplest to keep all of your 
license registrations in the same place.  For a networked license, this means an additional network 
share (or subfolder) on the server.  For a non-networked license, it means installing NDSR 2024 on 
the same computer where you have installed previous versions of NDSR.   
 
Windows Public Documents Folder 
For simplicity, this NDSR User Manual refers to Windows 10 or 11 as Windows. 
 
NDSR User Data includes backup files, output files, output-file headers, configuration files, header-
export files, and reports.  NDSR User Data is installed in the Public Documents folder by default 
(C:\Users\Public\Public Documents\NCC\).   
 
It is important to have all required permissions on NDSR User Data folders otherwise there might 
be problems with Windows File Virtualization. 
 
After NDSR has been installed, the NCC Public Documents folder may be revealed and its required 
permissions verified or set as described below. 
 
Verify permissions: 
 

1. Open Windows Explorer and locate the NCC Public documents folder 
C:\Users\Public\Public Documents\NCC\ 

 
2. Right-click on this folder. 

 
3. Select Properties from the popup menu. 

 
4. On the Security tab (and its advanced windows if necessary), verify that the Administrators 

group has ownership and Full Control of this folder and all of its child objects. 
 

5. Verify that the SYSTEM account has full control (of this folder and all of its child objects). 
 

6. Verify that the Users group has the following permissions (in this folder and all of its child 
objects): Modify, Read & Execute, List Folder Contents, Read, and Write. 

 
7. Verify that no user or group in which an NDSR user or administrator is a member 

(including Everyone) lacks any of the required permissions. 
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Use of NDSR Outside of the United States 
 
When using NDSR outside of the United States, the English (United States) computer settings are 
required on all computers to ensure optimal functionality.  
To check the settings, navigate to the Control Panel → Clock, Language, and Region. Under 
Region and Language, click Change the date, time, or number format.  Then select English 
(United States) from the Format drop down menu.  Click Apply then OK.  
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Installing NDSR, non-networked (Stand-alone) 
 
The NDSR installation has been programmed so that on Windows 10 or 11, you need to follow 
these prompts and then complete several steps manually (see "Windows Public Documents Folder"). 
 
NCC User Support (ndsrhelp@umn.edu) will send an email containing a link to download the 
NDSR 2025 installation.  Selecting the link will direct you to Google Drive.  No login is required to 
access this download.   
 
Hover the mouse at the top of the page and an options toolbar will drop down.  Select the 
DOWNLOAD ICON [ ].  Google Drive will warn that it cannot scan for viruses due to file size, select 
the DOWNLOAD ANYWAY button to continue.   
 
Open the NDSR 2025.zip folder.  Right click on the zip file select EXTRACT ALL, BROWSE to a 
location to store the files and select EXTRACT.  
 

1. Login as a member of the Administrator group.  Close any open applications. 
 

2. BROWSE to the file location open the setup.exe file to start the installation process. 
 

3. Continue to Step 4 on the next page. 
 

NOTE: It is recommended that the NDSR 2025 download be stored to a location that can be accessed 
for future installations, if necessary.   
 
Files can be stored in multiple locations (e.g., C:\drive, network drive, USB flash drive or 
CD).   

 
The following steps describe how to install NDSR using a CD or DVD drive. 
 

1. Login as a member of the Administrators group.  Close any open applications. 
 

2. Put the CD into the CD or DVD drive. 
 

3. If the installation process does not begin automatically, start it as follows: 
a. Select Start→Run, type D:/setup (where D: is the CD or DVD drive) and 

select OK OR 
 
b. In My Computer, go to the CD or DVD drive and open the file setup.exe. 

 
NOTE: To find your CD or DVD drive letter, select Start→Run and select the BROWSE button or go 

to My Computer or Windows Explorer.   
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The InstallShield Wizard window will open 
 

 
 

4. When the Welcome window opens, select the NEXT> button. 
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5. When the License Agreement window opens, select the radio button I ACCEPT THE TERMS 
OF THE LICENSE AGREEMENT, and select the NEXT> button. 

 

 
 

6. When the Choose Destination Location window opens, accept or change the destination 
folder and select the NEXT> button.  The default destination folder is C:\Program 
Files\NCC\ or C:\Program Files(x86)\NCC\ for 64-bit systems. 
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7. When the Setup Type window opens, select Typical setup and select the NEXT> button. 
 

 
 

8. When the Start Copying Files window opens, select the NEXT> button. 
 

 
 

The Setup Status window is displayed while the NDSR program files are copied from the 
installation CD to your computer’s hard drive. 
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9. When the InstallShield Wizard Complete window opens, select FINISH. 
 

This completes the installation process. 
 

 
 
After NDSR is installed, it must be registered (please read "Previous NDSR Registrations" and 
"Registering NDSR" before installing). 
 
Registering NDSR 
 
After NDSR is installed, each license must be registered by obtaining a computer-specific password 
from NCC.  If there is more than one non-networked license, this process is repeated for each one.  
If there is a single networked license, this process is done only once. 
 
The following steps describe how to register NDSR. 
 

1. Select Start→Programs→NDSR 2025→NDSR 2025.  When the Unregistered NDSR 
window opens, select the REGISTER button. 
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NOTE: If any message windows open before the Unregistered NDSR window, report them to NCC. 

 
2. When the Unauthorized Program: NDSR 2025 window opens, email site code to 

ndsrhelp@umn.edu.  NCC will provide you with the Password. 
 

 
 

3. Enter the NCC supplied password and select OK.  NDSR will open. 
 
Starting NDSR 
 
The following steps describe how to start NDSR. 
 

1. Select Start→Programs→NDSR 2025→NDSR 2025. 
 

2. When the Nutrition Data System for Research logo window opens, wait a few moments 
for the Folder, Project and Record Selection window to open. 
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3. Create a new project according to “Appendix 4, NDSR Tutorials” or “Chapter 3, Managing 
NDSR Projects”. 

 
NOTE: Projects and records created in one registration type (e.g., Demonstration) cannot be moved 

to a different registration type (e.g., Research). 
 
Transferring NDSR Registration 
 
You may move a registered copy of NDSR from one computer to another (or move the license 
folder from one drive or folder to another on the same computer) by transferring the NDSR 
registration.  
 
The following steps describe how to transfer NDSR registration from the sending computer (e.g., 
the computer from which NDSR will be removed) to the receiving computer (e.g., the computer to 
which NDSR will be moved). 
 

1. On the receiving computer, insert a removable drive (e.g., a USB flash drive) or open a 
network drive and create your temporary, empty license-transfer folder on it.  The NDSR 
registration will be transferred through this folder in a later step. 

 
NOTE: A CD or DVD drive will not work for this transfer, even if the recording software is 

compatible on the two computers. 
 

2. On the receiving computer, install and start NDSR (see "Installing NDSR, non-networked" 
and "Starting NDSR").  

 
3. When the Unregistered NDSR window opens, select the TRANSFER button. 

 
4. When the Transfer In window opens, specify the license-transfer folder you created in 

Step 1 in the Transfer Folder: field.   
 

Select the REGISTER TRANSFER button.  This creates a "request for registration" in your 
license-transfer folder.  You may leave this window open until you return to it in a later step. 
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5. From the receiving computer, remove the USB flash drive (if that is the location of your 
license-transfer folder).  Into the sending computer, insert the USB flash drive (or otherwise 
open your license-transfer folder). 

 
6. On the sending computer, Start NDSR.  When the Folder, Project and Record Selection 

window opens, select File→Transfer Out on the menu. 
 

7. When the Transfer Out window opens, specify your license-transfer folder in the 
Transfer Folder: field. 

 
Select the TRANSFER OUT button.  This transfers the NDSR registration from the sending 
computer to your license-transfer folder.  NDSR is no longer registered on the sending 
computer. 
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8. From the sending computer, remove the USB flash drive (if that is the location of your 
license-transfer folder).  Into the receiving computer, insert the USB flash drive (or 
otherwise open your license-transfer folder). 

 
9. On the receiving computer, go to the Transfer In window. 

 
NOTE: If you did not leave this window open in the earlier step, you may open it again by starting 

the NDSR program.  When the Unregistered NDSR window opens, select the TRANSFER 
button. When the Transfer In window opens, specify your license-transfer folder in the 
Transfer Folder: field. 

 
Select the TRANSFER IN button.  This transfers the NDSR registration from your license-
transfer folder to the receiving computer.  NDSR is now registered on the receiving 
computer, and the transfer is complete. 
 
You may delete your license-transfer folder or save it for transferring another license. 

 
Unregistering NDSR 
 
You may unregister NDSR in order to change from one license configuration to another (e.g., to 
consolidate a number of non-networked licenses into a single networked license, see "Installing 
NDSR, Networked License").  For each license that is unregistered, a confirmation code must be sent 
to NCC so that NCC can provide a replacement license. 
 

NOTE: Do not uninstall NDSR until you have unregistered it. Without a confirmation code, you will 
not be able to re-register NDSR. 
 
Do not uninstall NDSR until you have backed up your projects (see backup and restore in 
“Chapter 9, NDSR Utilities”). 

 
The following steps describe how to unregister NDSR. 
 

1. Start NDSR. 
 

2. When the Folder, Project and Record Selection window opens, press CTRL + ALT + 
SHIFT + K on the keyboard, all at the same time. 

 
3. When the Confirm Unregister window opens, select OK. 
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4. When the Program Unregistered window opens, carefully record the confirmation code.  
Select OK to unregister NDSR on this computer. 
 

 
 

Send this confirmation code to NCC by email at ndsrhelp@umn.edu.  NCC will then give 
you a password to re-register NDSR on another computer.  

  
5. Uninstall NDSR (see “Uninstalling NDSR”). 

 
Uninstalling NDSR 
 
You may uninstall NDSR one version at a time.  This allows you to move NDSR to a new 
computer, switch to a newer version, or end a study. 
 
NDSR may be uninstalled only by a member of the Administrators group. 
 
The following steps describe how to uninstall NDSR and optionally delete the NDSR folders. 
 

1. Backup your projects (see backup and restore in “Chapter 9, NDSR Utilities”). 
 

NOTE: When uninstalling protect your data by copying the backed up files to a secondary location  
(e.g., C:\drive, network drive, USB flash drive or CD). 

 
2. If you are continuing with NDSR, unregister or transfer the license (see "Unregistering 

NDSR" or "Transferring NDSR Registration"). 
 

3. Select Start→Settings→Control Panel. 
 

4. When the Control Panel window opens, select ADD OR REMOVE PROGRAMS. 
 

5. Look for NDSR 2025 in the list of programs, and highlight it.  Select the 
CHANGE/REMOVE button. 

 
6. When the Welcome window opens, select REMOVE and then the NEXT> button. 

 
7. When the Confirm Uninstall window opens, select OK.  NDSR is uninstalled. 

 
8. When the Maintenance Complete window opens, select FINISH. 
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9. After backing up your data and uninstalling NDSR, you may want to delete the NDSR 
folders—including any database, backup, export, output or report files that remain in them.  
For your protection, these user files are not deleted when NDSR is uninstalled—they may 
only be deleted manually.  On Windows 10 or 11, the default locations of the user files and 
program files are C:\Users\Public\Public Documents\NCC\NDSR 2025\, 
C:\ProgramData\NCC\NDSR 2025\ and C:\Program Files\NCC\NDSR 
2025\ or C:\Program Files (x86)\NCC\NDSR 2025 on 64-bit systems. 

 
If NDSR will not be reinstalled, its Crypkey License service may be uninstalled by opening 
a Windows command-line window, changing directories to the NDSR license folder, and 
executing the command "setupex /u". 

 
Installing NDSR, Networked  
 
NDSR can be networked so that users can share databases and/or a license.  Potential advantages 
include centralized system administration and information sharing.   
 
Networking requires an Amendment to your End User Software License Agreement with NCC, plus 
additional software installations as described below. 
 
NCC supports NDSR networking on Windows Server operating systems in consultation with your 
local system administrators. 
 
Note on required technical skills: networking the NDSR license and/or database requires technical 
knowledge beyond what is required for a "typical" NDSR installation.  To network the license, it is 
necessary to set up a shared network folder (or service) on the server, install and register the license 
there, grant security permissions to NDSR users, and on each client computer map a drive (or refer 
to the service) and edit the NDSR configuration file.  To network the database, it is necessary to 
configure and run a network database service, make firewall exceptions, modify environment 
variables, and on each client configure network connections, edit ODBC data sources, and edit the 
NDSR configuration file. 
 
Note on terminology: the terms “server” and “service” are often interchanged, so let’s define them 
briefly: a server is anything that provides a service (hardware, software, or human; directly or 
indirectly), and a service is something that is requested by a client and delivered to the client by the 
server.  For example, a server machine for NDSR runs server software including the Crypkey 
license server and/or the SAP SQL Anywhere personal or network database server.  Another server 
machine will commonly be a file server.  Each of these software servers operates with a number of 
components and processes including: 1) a server that provides a service and 2) a service that is 
requested and received by a client. The focus of a system-oriented person might be the server, and 
the only thing a user-oriented person might think about is the service; but both are correct.  This 
NDSR User Manual needs to describe documentation from both viewpoints, and so will use the 
term “server” where the vendor uses it, and the term “service” where the NDSR installer works with 
it on the list of Windows services. 
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Installing NDSR, Networked License 
A networked license is installed on a server’s shared network folder and referred to by each client 
computer through that client’s NDSR configuration file.   
 
To change the NDSR registration status from a non-networked license to a networked license see 
"Unregistering NDSR”.   
 
The following steps describe how to network the NDSR license using the file-based service.   
 

1. On the server machine, install NDSR as described in “Installing NDSR, non-networked”).  
On the Setup Type window, choose one of the following options: 

a. To install the NDSR application along with the license folder and license service, 
run the Typical installation. OR 

 
b. To install only the license folder and license service, run the Custom installation.  

On the Select Features window under the category “License Service”, select 
only the option “File-based service”. 

 

   
 

2. On the server machine, after installing the license folder but before registering the license, 
optionally move the license folder out of NCC ProgramData to a location that is specialized 
for shared network folders.  The license folder’s default location is 
C:\ProgramData\NCC\License_4 on Windows 10 or 11. 

 
On the server machine, share the license folder with NDSR users.  Every NDSR user must 
have the following permissions for both the share and the folder (and of course the folder's 
contents): Modify, Read & Execute, List Folder Contents, Read, and Write.  This involves 
two sets of permissions: one for the share and the other for the folder.  Start NDSR and 
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register the license (as described in "Registering NDSR”.  This will register NDSR on all of 
the client computers. 

 
3. On each client machine, complete the following steps: 

a. On each client machine, run the Typical NDSR installation as described in 
"Installing NDSR, non-networked”. 

 
b. On each client machine, map a network drive to the shared license folder, or 

determine how to address the server machine and its shared license folder using the 
Windows Universal Naming Convention (UNC, e.g., 
\\myServerName\myShareName) 

 
c. On each client machine, open the NDSR configuration file ndsr.ini and find the 

license path on the line with the default path of 
License=C:\ProgramData\NCC\License_4 on Windows 10 or 11. 

 
The default location of the NDSR configuration file ndsr.ini is 
C:\ProgramData\NCC\NDSR 2025 on Windows 10 or 11. 

 
d. In the NDSR configuration file that was opened in the previous step, change the 

license path so that it addresses the shared license folder. 
 

The license path may be specified in any of the following ways (UNC or mapped 
network drive): 

• \\myServerIPAddress\myShare\myLicenseFolder 

• \\myServerName\myShare\myLicenseFolder 

• myMappedDriveLetter:\myLicenseFolder 
 

NOTE: Unregistering NDSR on any client computer will unregister NDSR on all of the client 
computers. 
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Installing NDSR, Networked License and Database 
Installing NDSR with a networked database and license is done in three parts. 

• Part 1: NDSR Server installation.  
• Part 2: SAP SQL Anywhere installation.   
• Part 3: NDSR Client installations.   

 
Part 1:  NDSR Server Installation 
To network the NDSR license, run the Server installation of NDSR (or the Custom installation of 
the License Service) as described in "Installing NDSR, Networked License".   
 
To network the NDSR database, run the Server installation of NDSR or otherwise copy an installed 
NDSR database file to the database server (Do not grant any user access to the database folder). 
 
Part 2:  SAP SQL Anywhere Installation 
The following steps describe how to install SAP SQL Anywhere and configure it to run a network 
database service. 
 

1. NDSR databases are networked by the SAP SQL Anywhere software, which is provided 
and licensed by SAP (not by NCC).  A license for one network seat is required for each 
concurrent NDSR user.  

 
Obtain the necessary number of licenses and download instructions for SAP SQL 
Anywhere 17 from your vendor. 

 
2. Install SQL Anywhere. 

 
When choosing installation options, keep in mind that the UltraLite, MobiLink and SQL 
Remote components are not used by NDSR.  If you do not require them for other 
applications, do not install them.   
 
The following two screenshots show the recommended installation options (the first 
showing the top and the second the bottom of the option list). 
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Complete the installation by restarting Windows on the server. 
 

3. Optionally, update SQL Anywhere to the current release for your version. Check with your 
vendor for instructions on downloading and installing updates. 

 
NOTE: This step is not required.  The version that is tested by NCC is 17.4.2053.  You may need to 

apply the latest patches for security or performance reasons. 
 

4. To improve server efficiency, optionally remove the paths of earlier SQL Anywhere (or 
Adaptive Server Anywhere as it was formerly known) installations from the environment 
variable "PATH". 

 
5. To further improve server performance, optionally create the environment variable 

"SATMP" to identify the folder in which the SQL Anywhere network database service will 
write its temporary files.  This folder is best located on a hard drive with good capacity and 
speed. 

 
6. Open Sybase Central by selecting Start→Programs→SQL Anywhere 

17→Administration Tools→Sybase Central.  When the Sybase Central window opens, 
select View→Folders, and select the item “SQL Anywhere 17” in the left pane. 
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7. Select the Services tab on the right pane, right-click in the empty area of the pane, and 
select File→New→Service from the pop-up menu. 

 

 
 

8. When the first Create Service Wizard window opens, name the new service 
ndsrdbserv and select the NEXT> button to continue. 
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9. On the next Create Service Wizard window, select Network Database Server and 
select the NEXT> button to continue. 

 

 
 

10. On the next Create Service Wizard window, confirm that the executable file is 
C:\Program Files\SQL Anywhere 17\bin32\dbsrv17.exe on a 32-bit 
system or C:\Program Files\SQL Anywhere 17\bin64\dbsrv17.exe on a 
64-bit system and select the NEXT> button to continue.  
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11. On the next Create Service Wizard window, enter parameters like the following to name 
the service and each database it will run.  
For example, to network one NDSR 2025 database, enter parameters like the following 
(where “path” stands for the network database folder on your server). 

 
-n ndsrdbserv 
“path\ndsr 2025\database\ndsrdb.db” -n ndsrdb2025 
 
The default parameters on Windows 10 or 11 are as follows: 
 
-n ndsrdbserv 
“c:\ProgramData\ncc\ndsr 2025\database\ndsrdb.db” -n 
ndsrdb2025 
 
To network more than one NDSR database, enter a separate line for each database.  In the 
following example, the service named ndsrdbserv runs three NDSR 2025 databases, one 
NDSR 2024 database, and one NDSR 2023 database.   
 
-n ndsrdbserv 
 
"path\ndsr2025\ndsrdb.db" -n ndsrdb2025 
"path\ndsr2025A\ndsrdb.db" -n ndsrdb2025a 
"path\ndsr2025B\ndsrdb.db" -n ndsrdb2025b 
"path\ndsr2024\ndsrdb.db" -n ndsrdb2024 
"path\ndsr2023\ndsrdb.db" -n ndsrdb2023 
 
Select the NEXT> button to continue. 

 
These parameters continue to be editable on the Configuration tab of the Service 
Properties window after the service has been created. 
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12. On the next Create Service Wizard window, accept the default or select the account under 
which the service will run. 

 
On the next Create Service Wizard window, accept the default, "Automatic" startup type 
or select the service's startup type. 
 
On the final Create Service Wizard window, specify whether to start the service now, and 
then select the FINISH button to complete the Wizard.  
 
If you will run only NDSR 2008 or later databases on this service, you may start the service 
now and skip the next step. 
 
If you will run NDSR 2007 or earlier databases on this service, do not attempt to start the 
service now. Uncheck the option to start the service now, and select the FINISH BUTTON to 
complete the Wizard. The databases must first be updated for SQL Anywhere version 10 - 
12 (SA10 - SA12) before they will run on this SA12 service (see the next step). 

 
13. Update NDSR 2007 or earlier databases for SQL Anywhere version 10 - 12 (SA10 - SA12) 

and later. 
 

You may skip this step if you will run only NDSR 2008 or later databases on this service. 
 
Update each database and each client NDSR installation by running the “NDSR update for 
SA10 - SA12” (and later). 

 
a. Run the NDSR custom installation to install the “NDSR update for SA10 - SA12” 

(and later).  
 
b. Start the “NDSR update for SA10 - SA12” by running the executable file 

“ndsrupdatesa10.exe”. 
 
c. When the NDSR update for SA10 - SA12 window opens, select Help→ Help 

Topics from the menu and follow the instructions to complete the following 
updates of all client and server installations of NDSR 2007 or earlier: 

• Update each database on the server. 
• Update the INI file of each client NDSR installation. 
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14. Start the new network database service with the updated databases. 
 

 
 

15. Confirm that the new service has been started.  If the traffic-light icon is showing the green 
light, the service has been started and is running.  If the icon is showing the red light, the 
service has not yet been started.  To start the service, select the icon with the right mouse 
button and choose the Start command.  If the startup type is "automatic", the service will be 
started automatically every time Windows is restarted on the server. 

 
If you make a connection to one of the databases (using the Connections menu), you can see 
and manage the other databases that are running on the service. 
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16. If necessary, allow a firewall exception for the SQL Anywhere network database service 
“C:\Program Files\SQL Anywhere 17\bin32\dbsrv17.exe” on 32-bit 
system or “C:\Program Files\SQL Anywhere 17\bin64\dbsrv17.exe” on 
a 64-bit system.  The service must be able to listen for unsolicited incoming traffic from 
NDSR client database connections, by default on TCP port 2638. 

 
If another service is using TCP port 2638 on your server, the SQL Anywhere network 
database service can be switched to another port by inserting a parameter like "-x 
tcpip(port=2639)" as the first parameter on the Configuration tab of the Service 
Properties window.  Each client ODBC data source will then need a TCP/IP parameter like 
"host=myServerNameOrAddress:2639" to find the network database service on the new 
port. 

 
17. Close the Sybase Central window by selecting File→Exit. 

 
If you need to troubleshoot your network service, you can log startup and shutdown 
diagnostics to a file by inserting a parameter like "-z -o 
C:\ProgramData\NCC\NDSR 2025\Database\NetDbSrvStartuplog.txt  
" as the first parameter on the Configuration tab of the Service Properties window. 
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Part 3:  NDSR Client Installations 
The following steps describe how to install NDSR on each client computer and connect it to the 
networked license and database. 
 

1. Run the NDSR Client installation (see “Installing NDSR, non-networked”). 
 

2. Edit the license path in the NDSR configuration file ndsr.ini (see the client portion of 
"Installing NDSR, Networked License"). 

 
3. Complete the following steps to connect NDSR to the network database service. 

 
4. Open the Administrative Tools window and select Data Sources (ODBC) from the list. 

 
5. On the ODBC Data Source Administrator window, select the System DSN tab. 

 
6. Either create a new DSN or find the existing DSN named NDSR_2025 in the list, highlight 

it, and select the CONFIGURE> button. 
 

7. When the ODBC Configuration for SQL Anywhere window opens, verify or update the 
Data source name: and Description: fields. 
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8. Select the Login tab.  On the Action: field select "Connect to a running 
database on another computer".  Complete the Server name: and 
Database name: fields (to match the server name and database name you set in Part 2 
for the network database service, e.g., ndsrdbserv and ndsrdb2025). 
In some cases, the client computer can't find the network database service (e.g., 
ndsrdbserv) unless the server computer is named in the Host: field.  In some cases, an 
alternative to naming the Host machine here in the ODBC Configuration is to update the 
client machine's network connection (e.g., by specifying or correcting the primary and 
secondary WINS servers) so that it can find the network database service by name 
(ndsrdbserv).  
 

 
 

9. Select the ODBC tab and select the TEST CONNECTION button.  
 

Verify that the connection is successful.  
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Select the OK button to finish. 
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Installing Additional Setups  
 
An NDSR Typical or a Client installation provides one NDSR setup; that is, one instance of 
NDSR connected to one NDSR database.  But sometimes that’s not enough: additional setups may 
be desired to partition data, to register two different NDSR registration types (e.g., Research and 
Academic) on the same computer, or for other reasons. 
 
The easiest way to install additional NDSR setups is to run an NDSR Custom installation (or a 
modification as described below) and add one or two setups (with local or network databases).   
 
To add setups to a Typical installation, follow the instructions below that pertain to typical setups 
(ignoring those that pertain to other types of setups). 
 
To add setups to a Client installation, first follow the instructions in "Installing NDSR, 
Networked License and Database" to add databases to the network database service.  Then follow 
the instructions below that pertain to client setups (ignoring those that pertain to other types of 
setups). 
 

1. Install and register NDSR (Typical or Client), and then modify that installation as 
follows. 

 
2. Select Start→Settings→Control Panel→ADD OR REMOVE PROGRAMS (or 

Programs→Uninstall a Program). 
 

3. In the list of installed programs, select NDSR 2025, and then select the CHANGE/REMOVE 
(or Change) button. 

 
4. On the InstallShield Welcome window, select MODIFY, then select the NEXT> button. 

 
5. On the Select Features window, expand the category Additional Setups and the 

subcategories A and B. 
 

a. To add one database, select only one option under Additional Setup A.   
• Typical installation: LOCAL DATABASE 
• Client installation: NETWORK DATABASE 

 
b. To add two databases, select only one option under Additional Setup A and only 

one option under Additional Setup B (local or network database as above). 
 

NOTE: Do not deselect any of the currently-selected options or you will uninstall them. 
 

Select the NEXT> button. 
 

6. On the Maintenance Complete window, select FINISH to complete the modified 
installation. 
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7. For a Client installation, create ODBC DSNs for NDSR_2025_A and/or NDSR_2025_B 
as described in “Installing NDSR, Networked License and Database Part 3: NDSR Client 
Installations” beginning on page 2.26. 
 
For a Typical installation, examine the ODBC DSNs NDSR_2025_A and/or 
NDSR_2025_B that were created above by the NDSR modified installation. 
 
For any installation, if the license path of the initial NDSR configuration file has been 
customized, then customize the license path in the same way for each additional setup. 

 
8. To run an NDSR additional setup, select either Start→Programs→NDSR 2025A→NDSR 

2025A OR Start→Programs→NDSR 2025B→NDSR 2025B.  
 

If more customization or automation is desired, an unlimited number of NDSR setups can 
be created manually (without running the NDSR installation).  For each setup, create an 
ODBC DSN and an NDSR user folder that contains only an NDSR configuration file 
(ndsr.ini), an empty set of subfolders (additional files, backup, export, output, and reports), 
and a shortcut that tells the NDSR application to use this NDSR configuration file 
(ndsr.ini).  Customize this NDSR configuration file for this DSN and these NDSR user 
folders (or, if desired, shared network folders).   
 
Enter the path of the NDSR configuration file at the end of the shortcut target so that it 
looks like the following (all on one line, quoting only the path of the executable): 
“C:\Program Files\NCC\NDSR 2025\ndsr.exe” 
C:\ProgramData\NCC\NDSR 2025\ndsr.ini 

 
Reference Information 
 

• For information about errors in NDSR, refer to “Appendix 19, Troubleshooting”. 
 
 
 
 
 
 


